summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index fd4c70c..9f91313 100644
--- a/configure.in
+++ b/configure.in
@@ -50,8 +50,11 @@ AC_CHECK_MEMBERS([struct stat.st_rdev])
# Checks for library functions.
AC_HEADER_MAJOR
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
+AS_IF([test "x$cross_compiling" != "xyes"],
+ [
+ AC_FUNC_MALLOC
+ AC_FUNC_REALLOC
+ ])
AC_CHECK_FUNCS([memset strerror strrchr strtoul])
AC_CONFIG_FILES([