summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKieran Bingham <kieran.bingham@ideasonboard.com>2022-11-01 21:19:20 +0000
committerKieran Bingham <kieran.bingham@ideasonboard.com>2022-11-22 12:31:14 +0000
commit2619164b6998b2143e776a1c2f10140af9fe878b (patch)
tree4c9b370776e198d2288462c58713531a84750f09 /CMakeLists.txt
parent0e9c6b1e32f5ef38286ff2e0774ba69caf2eee7b (diff)
meson: Convert CMake to Meson build infrastructure
Provide infrastructure to be able to build the uvc-gadget library as a shared object and an executable which links against this as a dependency to implment the reference 'uvc-gadget' application. All existing cmake infrastructure is removed. This removes custom glob support that was previously used by an early development for Android, which is expected to be re-added later when required. Reviewed-by: Daniel Scally <dan.scally@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 0 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
deleted file mode 100644
index 5291256..0000000
--- a/CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-cmake_minimum_required(VERSION 3.0)
-project(uvc-gadget)
-set(CMAKE_BUILD_TYPE Release)
-
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wno-unused-parameter -Werror")
-
-include_directories(${CMAKE_BINARY_DIR}/generated)
-
-add_subdirectory(lib)
-add_subdirectory(src)
-
-# Generate config.h
-configure_file(${CMAKE_SOURCE_DIR}/include/config.h.in
- ${CMAKE_BINARY_DIR}/generated/config.h)