summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorDaniel Scally <dan.scally@ideasonboard.com>2023-01-16 07:58:12 +0000
committerDaniel Scally <dan.scally@ideasonboard.com>2023-01-16 13:10:03 +0000
commit006aa232ac92e3ccde06a3b1536d6e02e8496766 (patch)
tree200d7bb51f485d4a7c084f3fd587fdc0d8a1328f /lib/meson.build
parent66f0f93b78474109aa946ec5cd429d0d13d052f0 (diff)
libcamera: Add new libcamera source
Provide the integration of a libcamera source within uvc-gadget. This adds C++ support to the project and adds libcamera as an optional external dependency. Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Daniel Scally <dan.scally@ideasonboard.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/lib/meson.build b/lib/meson.build
index 680be1c..0931eef 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -15,8 +15,13 @@ libuvcgadget_sources = files([
'video-source.c',
])
+if libcamera.found()
+ libuvcgadget_sources += files(['libcamera-source.cpp'])
+endif
+
libuvcgadget = shared_library('uvcgadget',
libuvcgadget_sources,
+ dependencies : libcamera,
version : uvc_gadget_version,
install : true,
include_directories : includes)