summaryrefslogtreecommitdiff
path: root/lib/meson.build
diff options
context:
space:
mode:
authorDaniel Scally <dan.scally@ideasonboard.com>2022-11-30 13:31:08 +0000
committerDaniel Scally <dan.scally@ideasonboard.com>2022-11-30 13:48:26 +0000
commit1c18c451f3a48507e876cfdb03c0a6f2187f62cb (patch)
tree1ea466f89e854c35236b7a229981f123a6b8496d /lib/meson.build
parent90955f728061d0cbec4b470849a7f564637a6e3a (diff)
lib/timer: Add timer infrastructure
Some sources simply fill the buffers passed by the USB subsystem and return them as quickly as possible. Particularly with compressed formats operating at superspeed this rapidly results in unrealistic frame rates. Add infrastructure that allows us to define a specific framerate and introduce blocking calls that constrain those sources to the framerates expected by the host. Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Daniel Scally <dan.scally@ideasonboard.com>
Diffstat (limited to 'lib/meson.build')
-rw-r--r--lib/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/lib/meson.build b/lib/meson.build
index f6991d5..a0d67d5 100644
--- a/lib/meson.build
+++ b/lib/meson.build
@@ -6,6 +6,7 @@ libuvcgadget_sources = files([
'jpg-source.c',
'stream.c',
'test-source.c',
+ 'timer.c',
'uvc.c',
'v4l2.c',
'v4l2-source.c',