summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Scally <dan.scally@ideasonboard.com>2023-01-16 07:58:12 +0000
committerDaniel Scally <dan.scally@ideasonboard.com>2023-01-16 13:10:03 +0000
commit006aa232ac92e3ccde06a3b1536d6e02e8496766 (patch)
tree200d7bb51f485d4a7c084f3fd587fdc0d8a1328f /meson.build
parent66f0f93b78474109aa946ec5cd429d0d13d052f0 (diff)
libcamera: Add new libcamera source
Provide the integration of a libcamera source within uvc-gadget. This adds C++ support to the project and adds libcamera as an optional external dependency. Reviewed-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Kieran Bingham <kieran.bingham@ideasonboard.com> Signed-off-by: Daniel Scally <dan.scally@ideasonboard.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index b5d7e2b..c928170 100644
--- a/meson.build
+++ b/meson.build
@@ -1,11 +1,12 @@
# SPDX-License-Identifier: CC0-1.0
-project('uvc-gadget', 'c',
+project('uvc-gadget', 'c', 'cpp',
meson_version : '>= 0.56',
version : '0.2.0',
default_options : [
'werror=true',
'warning_level=2',
+ 'cpp_std=c++17',
],
license : 'LGPL 2.1+')
@@ -52,6 +53,8 @@ summary({ 'Sources': uvc_gadget_git_version, }, section : 'Versions')
# Configure the build environment.
cc = meson.get_compiler('c')
+libcamera = dependency('libcamera', required : false)
+
subdir('include')
subdir('lib')